Не работает IGMP/Multicast(IPTV) на EdgeRouter X

Тема в разделе 'Коммутаторы и маршрутизаторы', создана пользователем Maaxxx, 4 июн 2019.

  1. Maaxxx Member
    Maaxxx

    Maaxxx Member

    Регистрация:
    2 июн 2019
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    6
    Пол:
    Мужской
    Купил EdgeRouter X и столкнулся с неработающей IPTV приставкой. При обращении к провайдеру Планета отвечают, что не знаю как настраивать на таком роутере. Схема подключения такая: От провайдера приходит интернет с поддержкой IPTV в eth0, IPTV подключена к eth1, в eth2-eth4 подключены wi-fi точка, стационарный компьютер и телевизор. Пробовал настроить по инструкции https://help.ubnt.com/hc/en-us/articles/204961854-EdgeMAX-Set-up-IGMP-proxy-and-statistics. Но он не работает после таких настроек.
     
  2. Maaxxx Member
    Maaxxx

    Maaxxx Member

    Регистрация:
    2 июн 2019
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    6
    Пол:
    Мужской
    • Получилось настроить следующим образом, надеюсь вам тоже подойдет. Подключаемся по консоли, начинаем прописывать команды (добивайте клавишей TAB, могут быть у меня ошибки в написании слов =))
    configure #вход в режим конфигурации
    edit protocoles igmp-proxy #редактируем протокол igmp
    set interfaces eth0 alt-subnet 0.0.0.0/0 #eth0 это порт в который подключен кабель от провайдера
    set interfaces eth0 role upstream
    set interfaces eth0 threshold 1
    #далее, я прописывал куда перенаправлять данный трафик, у меня 3 порта настроены в switch0
    set interfaces switch0 alt-subnet 0.0.0.0/0
    set interfaces switch0 role downstream
    set interfaces switch0 threshold 1
    commit
    save
    Далее заходим на GUi, заходим в закладку firewall/NAT
    У меня в данной закладке два правила WAN_IN и WAN_LOCAL (они создались автоматически, когда я запускал настройку роутера через wizard).
    В этих правилах необходимо добавить по два правила (разрешающих) для трафика udp и igmp
    Для этого выбираем wan_in => config => edit rules
    Пишем название правила, и в закладке Basic, ставим галочки enable, accept, UDP, save
    Далее добавляем еще правило для igmp, все то же самое, только вместо UDP выбираем choose a protocol by name(активируется птичка, в которой нужно выбрать протокол igmp)
    Также сделать и с WAN_LOCAl.
    Один момент, разрешающие правила должны стоять сверху запрещающих. Созданные правила можно перемещать мышкой.
    После этого, iptv начало работать.
     

Поделиться этой страницей